
Custom Map Workflows: 
 
Workflow 1 – Converting a downloaded GeoTiff (calibrated) Canadian Government 
1:50,000 topographical map to a Garmin Custom Map for use on the Garmin Oregon 450 
handheld GPS plotter. (Other devices similar). 
 

1) Download the NRC (Natural Resources Canada) topo map index  in .pdf or .tiff 
format, for the province you are interested in, from here: 

 
http://geogratis.cgdi.gc.ca/geogratis/en/option/select.do?id=777039C7-69ED-
B1A1-A4AE-62113E4F1481 
 
 
Alternatively, you can download this file 
ftp://ftp2.cits.rncan.gc.ca/pub/index/nts_snrc.kmz 
And open it in Google Earth to see the index grid overlaid on Google Earth. 
 
From viewing the index, note the map sheets you need to cover the area you are 
interested in (e.g. 031f02) 

 
2) Download the NRC (Natural Resources Canada) geotiff maps that you are 

interested in from: 
ftp://ftp2.cits.rncan.gc.ca/pub/cantopo/50k_geotiff/ 
 
If the sheet you need is not available in this directory (i.e. not available in geotiff 
format) you will need to download the regular image TIFF file and calibrate it. 
This procedure will be covered separately in a different document. 

 
3) This is a good time to determine any re-scaling (compressing) requirements of the 

map(s) you want to load on your Garmin. Garmin custom maps are loaded on 
your handheld device as a number of 1024 x 1024 pixel “tiles”. The maximum 
number of tiles you can load at any one time is 100 (whether these tiles are all 
from one map or from several). Consequently, the higher the resolution of the 
map you begin with, the more tiles it will take to display it on your handheld 
Garmin. If the maps are of high enough resolution, you may run out of tiles before 
you are able to load all the maps you want. The way around this is to re-scale or 
reduce the resolution of the maps, which means fewer tiles will be required to 
reproduce the map, and therefore there will be more tiles left to cover a greater 
total area. The cost will be some loss of quality in the map displayed on the 
handheld. MAP2CMAPC supports this re-scaling when creating Garmin Custom 
Maps using a <Rescale Map> function (see Step 17, Edit -> Rescale Map, below). 
Before we get to that step though, we can estimate what our re-scale percentage 
should be, based on the file size of the map(s) we have downloaded. Proceed as 
follows: 

a. Note the image size of the downloaded map (e.g. sheet 031f02 is  12179 x 
8658 pixels.) 

http://geogratis.cgdi.gc.ca/geogratis/en/option/select.do?id=777039C7-69ED-B1A1-A4AE-62113E4F1481
http://geogratis.cgdi.gc.ca/geogratis/en/option/select.do?id=777039C7-69ED-B1A1-A4AE-62113E4F1481
ftp://ftp2.cits.rncan.gc.ca/pub/index/nts_snrc.kmz
ftp://ftp2.cits.rncan.gc.ca/pub/cantopo/50k_geotiff/


b. Divide each dimension by 1024. e.g. 12179 / 1024 = 12      8658 / 1024 = 
8.5. 

c. Multiply the two results together to get the total number of tiles. E.g. 12 * 
8.5 = 101 tiles.  This is only a rough estimate, as we are going to save 
some tiles by cropping the unwanted margins of the map sheet. Reduce 
this number by 30% to account for tiles we will not have to use as we will 
be cropping the unwanted borders off the map. As it turns out, sheet 
031f02, when cropped to just the map, takes 70 tiles to reproduce at full 
resolution.  

d. Decide if you can afford to “spend” this many tiles per sheet. If not, you 
will have to use the re-scale function in step 17. To determine an 
approximate re-scale percentage, divide 100 (total number of tiles you 
have) by the number of map sheets you need to load (based on the area 
coverage you want). Say I want to cover an area of four map sheets – that 
means each map can be no more than 100/4 = 25 tiles. If we re-scale the 
map by 50% it will be 6089 x 4329. This equates to 5.9 x 4.2 tiles, or 24 
tiles. Minus 30% savings for cropping the border, and we arrive at 17 tiles 
to cover one map at 50% re-scale. This would let us cover our four maps 
in 17 x 4 = 68 tiles, giving us plenty to spare. 

 
Here is a table giving rough numbers of total tiles required vs. re-scale percentage 
for the NRC geotiff maps: 

 

Rescale 
Horiz 
pixels 

Vert 
Pixels 

Horiz 
Tiles 

Vert 
Tiles 

Number 
Tiles 

Less 
30% 
(crop 
margin)

Total 
Tiles 
Required 

100% 12284 8810 12 9 103 31 72
90% 11056 7929 11 8 84 25 59
80% 9827 7048 10 7 66 20 46
70% 8599 6167 8 6 51 15 35
60% 7370 5286 7 5 37 11 26
50% 6142 4405 6 4 26 8 18
40% 4914 3524 5 3 17 5 12
30% 3685 2643 4 3 9 3 7
20% 2457 1762 2 2 4 1 3
10% 1228 881 1 1 1 0 1

 
 
 

4) Open the downloaded geotiff map in a graphics viewer program and view it full 
size (e.g. IrfanView, Ctrl-H). 

 
 

5) Note the Projection, Datum, and UTM Grid Zone located on the bottom or side 
margin of the map. The data will look something like this: 

 



 
 

For example, from the map 031f02, We get: 
 
- PROJECTION: Transverse Mercator Projection 
- DATUM: North American Datum 1983 (NAD83) 
- GRID: Universal Transverse Mercator Grid (UTM) 
- GRID ZONE: Zone 18 

 
6) If you haven’t already done so, download and install MAP2CMAPC software, 

available here: 
 

http://www.the-thorns.org.uk/mapping/down.html 
 

7) Download and install the following software (MAP2CMAPC needs these to 
operate): Make sure to note where the .exe executable files are installed on your 
system. 

a. 7-Zip >>>> From http://www.7-zip.org/  (This is a compression algorithm 
used to create the .kmz file format) 

b. FWTools >>>> From http://fwtools.maptools.org/ (This is a set of Open 
Source GIS binaries for Windows). 

 
8) Start MAP2CMAPC 

 
9) Select Edit -> Locate -> 7-zip, and in the dialog that opens, navigate to and select 

the 7z.exe file that was installed when you installed 7-Zip. For example, in 
C:\Program Files (x86)\7-Zip\ 

 

http://www.the-thorns.org.uk/mapping/down.html
http://www.7-zip.org/
http://fwtools.maptools.org/


 
 

10)  Select Edit -> Locate -> FWTools Listgeo, and in the dialog that opens, navigate 
to and select the listgeo.exe file that was installed when you installed FWTools. 
For example, in C:\Program Files (x86)\FWTools2.4.7\bin\ 

 

 
 

11) Open the map in MAP2CMAPC with File -> Open Calibration 
 



 
 

12) In the dialog box, select geotiff for file type, then select the map 
 

 
 



13) In the dialog that opens, select the UTM zone of the map (from step #5), then 
click <Not WGS84> since the downloaded map’s Datum is NAD83 and not 
WGS84. 

 

 
 

14) From the dialog that opens, select the Datum of the map (e.g. NAD83) from step 
#5, click <OK>. 

 

 
 



15) The map loads and is ready to be viewed, edited (cropped, re-scaled, warped, etc.) 
, and finally exported as a Garmin custom map KMZ file. 

 

 
 

16) Note that the map has been “converted” to WGS84 datum on import, as shown by 
the 5th line down in the above screenshot. As such, one should now always select 
“WGS84” when prompted for the datum (e.g. when warping). 



 
17)  Click Edit -> Preferences, and set up as follows: 

 

 
 

Note that selecting <Write WGS84 version of input> has no effect as the geo tiff 
map has already been converted to WGS84 Datum on import, as described above 
in Step #16. 

 
Note that if you check <Transparent KMZ?>, the final .kmz file will be semi-
transparent when viewed in Google Earth, although it will always be 100% 
opaque (solid) when viewed in Garmin BaseCamp or on the Garmin handheld. 

 
Note: The GarminDraw Order (01-99) value is used to determine whether to draw 
the custom map on to of or underneath any existing vector maps on the Garmin 
handheld device. Values of 01-49 will cause the custom map to be drawn 
underneath any vector maps, whereas values from 50-99 will cause it to be drawn 
on top of any vector map. 

 



18) Rescale the map if required, depending on the size of the map and the number of 
tiles it will take up on your Garmin (see calculation, step #3). Select Edit -> 
Rescale Map 

 

 
 

19) In the dialog that opens, enter <50> (or whatever your desired value is – larger 
number = better quality map that consumes more tiles) and click <OK> 

 

 
 



Note that rescaling these maps by, for example, 50% results in a single sheet 
requiring 20 “Garmin Tiles” as opposed to the approx. 70 tiles required for a non-
rescaled map.  Different degrees of rescaling (higher or lower than 50%) will 
result in differing amounts of “tile savings”. Note that the Oregon 450 only allows 
a maximum of 100 tiles. The less you rescale the map, the more tiles you use, the 
better the “resolution” of the map (i.e. the farther you can zoom in when viewing 
the map before pixilation occurs), but the more tiles it will take. Users will have 
to experiment to find which degree of rescaling best fits their needs. 

 
20) Warp the map to make it North-up and equirectangular (straight edges), in 

preparation for cropping the borders. Select Edit -> Warp Map 
 

 



 
21) In the dialog that opens, select the following settings. Click Next. 

 

 
 

Note that the values entered here are what you want the map to be after you have 
warped it. I have selected Lat/Lon (Plate Carree) and WGS84 as both Google 
Earth and the Garmin work well with this datum and grid at the relatively small 
scales (small areas) covered by these topo maps. 

 
22) View map to check everything is ok, and check the co-ordinates of some known 

points. Click <View> 
 

 



 
23) Use the cursor, map, map’s grid, and the crosshair readouts at the top left to check 

that the grid and calibration are ok. Also check a couple of known locations (i.e. 
place crosshairs on location and read coordinates from the top left – compare with 
known values) 

 

 



 
24) If you are connected to the internet, you can right-click on an area of the map and 

a Google Earth thumbnail image, centred on the point at which you clicked, will 
pop up. This is another easy way to check coordinates.  

 

 



 
25) Close Map View window, then select Edit -> Crop Map 

 

 
 

26) Click 200% to blow up the view, then using the scroll bars (you may have to drag 
the corner of the window open a bit to see the scroll bars fully) locate the top left 
corner of the actual map image. Position the crosshairs at the top left corner, just 
inside the black border, and left click to set this point. 

 

 



 
27) Scroll to the bottom right corner using the scroll bars, then position the crosshairs 

at the bottom right, just inside the black border, and right click to set this point.  

 
 

28) Select <crop>.  Then view the map again and check it. Close the map view 
window. 

 
29) Save the map as a Garmin Custom Map .kmz. Select File -> Write Garmin 

Custom Map 

 



 
30) If you selected <Advanced Garmin Tile Control> in the Edit -> Preferences 

dialog (step 9) , the Garmin Tile Control window will open and allow you to 
uncheck any unneeded tiles (to save tile #’s because of the 100 tile Garmin limit) 

 

 
 

31) Uncheck the tiles you don’t want ( a red X appears) then click <ok>. Choose a 
location and name for the custom map and click <save>. 

 

 



 
32) When the custom map file is done, the MAP2CMAPC screen will announce that 

it is done like this: 
 

 
 

33) Exit MAP2CMAPC, and open  the .kmz file in Google Earth to make sure 
everything makes sense. 

 Garmin’s custom maps directory: (e.g. 
G:\garmin\custom maps\ 

 
 

gether. And remember that the total of all custom 
maps cannot exceed 100 tiles. 

www.the-thorns.org.uk/mapping/

 
34) Copy the .kmz file to your

Note, you can only enable or disable all custom maps on your Garmin as a group.
Therefore if you have two .kmz files in the custom maps directory, they are both 
enabled together or disabled to

 
35) If you have not already done so, be sure to support John, author of 

MAP2CMAPC, by sending the very small amount required for a registered 
version of the software. Go to http://  and click 
on the Paypal <Buy Now> button.  

http://www.the-thorns.org.uk/mapping/

