MAPC2MAPC Help pages : beginners' guide
Overview
How to ....
Grids and Datums
Map Images
Uses
System Issues

This page is to get you started.....

MAPC2MAPC is a program to manipulate digital maps and make them portable between systems.

So, what have you got, what do you want to do with it and where do you want it to go?.....

Have a look in the Glossary for terms

MAPC2MAPC has two different user interfaces. Wizard mode is the default for new users and is designed to simplify the common operations.Click here for a tutorial and sample files.

Expert mode uses traditional Windows menus and is covered below. You can switch between the interfaces at any time : click the menu icon in Wizard mode or use File>Wizard mode in Expert mode.
What have you got?
  - A digital map from another program or downloaded from the internet.
              If this is two files - an image and a calibration file (e.g .PNG + .CAL) then use File>Load Calibrated Map and Open the calibration 
               file.
              If it is a single file - KMZ,KML,SID,GeoTIFF,KAP - then use File>Load Calibrated Map to open that.
              If it is a file that GDAL will decode the use File>Open via Gdal This will usually create a TIF image and TFW calibration.
              MAPC2MAPC always tries to load the whole map into memory so very large maps - hundreds of million of pixels - may not load.
   - A map image without a calibration file.
              Load the image with File>Load Image for calibration and decide how you want to supply the information. An easy way is to trace a                      path of 4 or more points on Google Earth then click the same points on your map. See here.
   - A paper map
              You need to scan the paper map and save the scanned image (PNG is usually best) then proceed as above.

Once the map is loaded and calibrated use View to see it on the screen. Use the mouse wheel or CTRL+/- to zoom the view. Right click will show an image of the same place on Google Earth. If you zoom you can move the map with scroll bars or click and drag with the mouse.

What do you want to do with it?
  - To change the map use the Edit functions.

Where do you want it to go?
  - Have a look at the formats page which may help you decide what you need to do.
  - File>Write Calibrations (or File>Write map and calibrations if you have edited the map) writes the calibration files that you select in                  Edit>Preferences. Calibrations are written to the same directory as the original, if writing an update map you may choose where.
  - File>Write Garmin Custom Map does just that. You can choose whether to leave out unneeded map pieces
  - File>Write Mobile Atlas Writes one of several formats of Mobile Atlas for application such as Maverick, Orux, BCNav etc
  - File>Write Trekbuddy Map  Writes the map in a form to use with Trekbuddy - a JAVA application for many platforms
  - File>Write JNX File  Writes a file on the unoffical Birdseye format for Garmin units. More here. Only one level is written but a program  
         JNXMERGE allows the combining of several maps of the same area at different scales.
  - File>Write ANDROZIC MAP+OZF2  Makes the map into a format suitable for Androzic or OZI Explorer

Note that some Write operations reprocess the map and may take a few minutes.